We are experiencing an issue with Device Management Agent (DMA) installation.
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 28 days ago. Oct 19, 2018 - 08:18 PDT
Investigating
Our team is investigating an issue that is preventing the installation of the Device Management Agent (DMA) on end user machines.
At this time, there is no estimated time to resolution. An update will be provided as soon as one is available.
Posted 28 days ago. Oct 19, 2018 - 07:38 PDT
This incident affected: DeploymentPro.