BitTitan.com and manage.bittitan.com are inaccessible
Incident Report for BitTitan
Resolved
The issue has been resolved.
All operations are now back to normal.
Posted 7 months ago. Feb 26, 2018 - 03:43 PST
Identified
Our team has identified the issue and is actively working on the fix.
Posted 7 months ago. Feb 26, 2018 - 02:31 PST