BitTitan.com is inaccessible
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 16, 2018 - 09:19 PDT
Update
Our team has confirmed manage.bittitan.com and migrationwiz.bittitan.com are not impacted.
At this time there is no estimated time to resolution.
Posted 5 months ago. Jul 16, 2018 - 08:57 PDT
Investigating
Our team is investigating the issue affecting access to our site.
Posted 5 months ago. Jul 16, 2018 - 08:48 PDT
This incident affected: BitTitan Website.