Unable to send emails from BitTitan
Incident Report for BitTitan
Resolved
Mail sending is back to normal. This incident has been resolved.
Posted 7 days ago. Sep 16, 2018 - 03:57 PDT
Investigating
We are currently investigating an issue that is preventing emails being sent from BitTitan.com.

Our Support team can still be reached by direct email at Support@BitTitan.com

This issue is potentially affecting the following components:

Support Requests
New Account Registrations
Password Resets
Purchases
Device Management Agent (DMA) Installation emails
Project Statistics
Posted 7 days ago. Sep 15, 2018 - 23:15 PDT
This incident affected: BitTitan Website, MSPComplete, MigrationWiz, and Deployment Pro.