Backend scheduling server issues.
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 4 months ago. Dec 18, 2017 - 15:30 PST
Investigating
Bittitan development engineering team is currently investigating an issue with our back end scheduling servers that my cause a variety of issues that may lead to customer impacting events. At this time there is no estimated time to resolution.
Posted 4 months ago. Dec 18, 2017 - 11:37 PST