Office 365 public folder migrations are experiencing errors when migrating Task, Calendar, and Contacts folders.
Incident Report for BitTitan
Resolved
We are no longer receiving reports of this error affecting Public Folder migrations. If you are still experiencing this error, please contact BitTitan Support by email at Support@BitTitan.com
Posted about 2 months ago. Sep 20, 2018 - 14:15 PDT
Monitoring
Microsoft is in the process of rolling out a patch to address this error. Some tenants have already received the patch, but there is no ETA on when it will be released worldwide.

If you have received this error, please resubmit your migration to see if your tenant has been patched. If the error continues, please wait 24 hours and attempt your migration again.
Posted 2 months ago. Sep 14, 2018 - 13:37 PDT
Identified
Microsoft unexpectedly changed the process required to search for items in Public Folders. This is a high impact change which appeared to happen on August 28th, 2018. Microsoft is aware of the issue and working on a fix for resolution. Updates will be posted as they are made available.
Posted 2 months ago. Sep 06, 2018 - 09:20 PDT
Investigating
Our team is investigating the issue that is causing public folder migrations to produce the following error, "Public Folder error: "Expected an item Id but received a folder Id"." Migrating normal Office 365 public folders do not appear to be exhibiting this error. We have confirmed this issue is not related to the MigrationWiz code, and testing for a workaround is in progress. At this time there is no estimated time to resolution.Updates will be posted as they are made available.”
Posted 2 months ago. Sep 05, 2018 - 13:52 PDT
This incident affected: MigrationWiz.