Unable to create a support ticket from MSPComplete
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 27 days ago. Mar 24, 2018 - 12:15 PDT
Identified
Our development team is still investigation the issue that is affecting our contact page. They were able to restore that ability to submit a ticket, however, the ticket contents are being stripped from the message.

If you need assistance, please email the Support Team directly at Support@BitTitan.com.
Posted 28 days ago. Mar 23, 2018 - 16:07 PDT
Investigating
Our Operations team is investigating an issue that is preventing users from submitting a Support request from https://account.bittitan.com/contact. At this time, please email Support@BitTitan.com to receive assistance with our product.
Posted about 1 month ago. Mar 19, 2018 - 09:51 PDT