BitTitan.com and manage.bittitan.com are inaccessible and not rendering, respectively.
Incident Report for BitTitan
Resolved
This incident has been resolved.
Posted 5 months ago. Dec 11, 2017 - 19:42 PST
Monitoring
This incident has been resolved. Our network provider incurred a configuration change outside of our control, causing some clients to fail to connect successfully. Our Operations team is currently working with our network provider to make sure that no further interruptions occur.
Posted 5 months ago. Dec 11, 2017 - 13:47 PST
Investigating
Our development team is investing an issue where BitTitan.com and manage.bittitan.com are inaccessible and not rendering, respectively.
At this time there is not an estimated time to resolution.
Once an update is made available, it will be forwarded.
Posted 5 months ago. Dec 11, 2017 - 09:21 PST